Subject: Re: Archive Viper 150 not working with 1.0_BETA
To: Stephen J. Roznowski <>
From: Tobias Abt <>
List: amiga-dev
Date: 08/01/1994 11:51:50
> My Archive Viper tape drive no longer seems to be working under
> 1.0_BETA.  (940726 sup) using the A3000 kernel. Whenever I attempt to
> access the drive, I get the following errors:
> 	st0(ahsc0:4:0): illegal request
> 	st0: cannot set selected mode
> But it appears to be found during autoconfig:
> ahsc0 targ 4 lun 0: <ARCHIVE VIPER 150  21247-011> SCSI1 sequential removable
> st0 at scsibus0: rogue, density code 0x0, 512-byte blocks, write-enabled

This also happens to me using my Sankyo CP150E QIC streamer. This appeared
for me using the 940709 kernel, but I have been away from NetBSD for some
time, so this might even be an older problem.
My guess is that it is because my Sankyo is only SCSI-1 and I guess someone
implemented some SCSI-2 commands...

> Please help.
> -SR

Bye,                    \|/
  Tobias                @ @
| Tobias Abt                                  |
| email: |
|   irc: tabt@#AmigaGer                       |