Subject: Re: Son of unexpected trap
To: David Jones <>
From: Andrew Cherry <>
List: amiga-dev
Date: 07/20/1994 18:54:30
David Jones writes:
 > > Again, my set up is A2000, GVP G-Force 040 with 12MB RAM.  The only other
 > > card is the IOExtender.  Also, a kernel compiled from 7/13/94 sources
 > > (possibly 7/12) boots fine.
 > What happens if you remove the IOExtender?

Same thing happens with or without the IOExtender.
While I had the box open, I tried a bunch of different configs.
My complete hardware configuration is:

Boards:	G-Force 68040 w/12MB RAM, IOExtender, Flicer-Free Video 2
Drives:	Seagate ST31200N (1 gig, SCSI ID 0)
	Quantum PD105S (100 meg, SCSI ID 1)
(No, I didn't forget to mention my tape drive.  That's my next purchase.
 Until then, I'm living dangerously.)

I have tried removing the IOExtender.  I've tried swapping the G-Force
with a GVP 22MHz 030 Combo (5MB RAM), and taking out the IOExtender.
I have also tried going without the Seagate and without the Quantum (but
not without both!).  The only thing I haven't done is remove the Flicker
Free Video 2 (it's a pain).  I don't think it is very likely
that the FFV2 is the problem, since the Amiga doesn't actually see it;
it just sits between the Denise and its socket, and taps the signals.

Anyway, all of the above setups result in an unexpected trap.  It always
occurs somewhere in configure(), but in some of the setups
above, it didn't happen in setroot().  Well, I'll keep trying. :-)

Perhaps something is going wrong during compilation?  I don't get any
compile errors, but it is possible that something is being munged.
Is anyone else with an A2000 and a GVP accelerator running a currrent

-Andrew Cherry