Subject: More info on the WarpEngine SCSI problem
To: None <,>
From: Tom Hayko <>
List: amiga-dev
Date: 06/29/1994 01:59:02
Well, something like my problem has happened again with the new drive.
Here is what I got while untarring an archive (with my comments in
--- start of output ---

SIOP: Parity Error
siopchkintr: target 4
scripts 80bcff0 ds 8211028 regs 40040000 dsp 80bd0f8 dcmd 1f00000

(the next line scrolled off the screen because the line below kept
 repeating itself, but I did managed to see sstat0 1)

waiting: tgt 4 cmd 03 sbcl 21 dsp 8010d1b0 (+1c0) dcmd 19000020 ds 559028
--- end of output ---

and the las line kept scrolling on for a couple of minutes until I did a
control-amiga-amiga and rebooted.  I'm pretty sure that before, the first
message was not a Parity Error.

Once I rebooted, I tried to do and fsck on the device that I was untarring
to at the time and I got the following:

--- start of output ---

siopchkintr: istat a dstat 80 sstat0 1 dsps 8211412 dsa 8211028 sbcl 67 sts ff msg 3
wesc0: siop id 7 reset

cannot read: blk 17152

--- end of output ---

At this point, fsck asked if I wanted to continue, and I typed N, and
then I couldn't read from the disk at all.  Anything I tried came back
with the message I/O error.  I'm also not 100 per cent sure, but I think
the first line of this message was the same as the line that scrolled off
he screen in the previous message.  I never did get dropped into the kernel
debugger, so I wasn't able to get a symbolic stack trace.  

Is this possibly caused by an incompatibility between the drive I'm using
and the WarpEngine/NetBSD combo?  Could it be that the synchronous
negotiation is too quick for the drive (I'm really guessing here because
it's about the only thing that I change on the WarpEngine).

I'm running Michael Hitch's kernel with AGA support dated 940620 from

Tom Hayko