Subject: NetBSD DAT tape problems
To: None <>
From: Patrick Vervoorn <vervoorn@dutiws.TWI.TUDelft.NL>
List: amiga-dev
Date: 05/09/1994 10:51:05

Recently I wanted to try a DAT drive to make a backup of my current
NetBSD-Amiga setup, so I booted up NetBSD with the tapedrive attached and
turned on. However, when booting I get a kernel trap with the 940417 kernel
from sun-lamp/net-1 (which I run). I have tried both the newer 940427
kernel and the experimental Warp+IDE kernel, but both of these do (more or
less, I'll come back to that later) the same thing.

As an aside, why is the (newer, updated?) 940427 kernel so big? Also,
running vmstat with this kernel gives some weird error messages about some
_vmstat_blahblag functions bot being in the kernel?

OK, my system is: A4000/040, 8MB Fast, GVP series II scsi with a DEC
DSP3133LS at id 0 and an external WangDAT 3400DX at id 5. Also a Seacrate
st1144a is connected to the internal IDE (For Linux :). No other hardware

The WangDAT works like a champ under AmigaOS.

Now for the boot-up messages I get:


everything goes pretty normal...
GVPIIscsi0 [2017/11]
sd0: DEC DSP3133LS rev 440E, 2613530 512 byte blocks
sd0 at GVPIIscsi0, slave 0
st0: WangDAT Model 3400DX rev 1.10
st0: Unsupported tape device, using GENERIC
panic: kernel jump to zero
hit any key to boot/dump
> [I press enter] trap: bad kernel access at 2
trap type 8, code = 4c5, v=2
pid=0, pc=00000dae, ps=2004, sfc=0001, dfc=0001
registers: etc, etc.
blah blah
Kernel stack dump:
blah blah
panic: MMU fault
hit any key to boot/dump

ad infinitum, until the keyboard locks up, then it's ye good olde
three-fingered salute...


I have tried patching the _st_pretend_tobe_mt variable to about every
possible value (as per the README.vmunix.tapeII doc), but it still fails
with exactly the same messages.

Like I mentioned, I've tried other kernels: the 940427 sun-lamp one and the
Warp + IDE test kernel from Michael Hitch I found at
(which probably would have had other problems since I also have an IDE disk
connected (IDE sd0 <-> SCSI sd0). Anyhow, this last one also failed but
this time it jumped into some sort of boot-monitor, which I didn't quite
understand... :)

My guess is something goes very wrong when the kernel finds a tape device
it doesn't recognize; it seems to jump to some bogus address...

If anyone has any ideas, or if you need more info, let me know... I would
very much like to backup NetBSD, before something goes very wrong... :)