Subject: Re: New kernel break programmes.
To: Arthur Hoffmann <>
From: Andy Heffernan <>
List: amiga-dev
Date: 04/27/1994 00:29:09
	I'm pretty much in the same boat as you.  I'm running a fairly
new kernel now with binaries from the 17Apr94 snapshots on  It looks like the kernel or some binaries have
trouble because of the recent changes.  I'll bet if you looked at the
offending archive file you would see that its length is zero.  Beware
of strip, because it will strip files down to nothing as well.  In the
case of strip, the problem appears to be the ftruncate() call.  I don't
know if ar uses ftruncate() too, but we shall see.

	Of course, now I'm getting occasional bursts of "ser_fastint:
buffer overflow" messages as well.

	Never a dull moment!

> Hi
> I just sent a message before mentioning that I couldn't buld new
> kernels anymore, some problem with ranlib.
> the problem seems to be the new kernels.
> I suped the changes for 26.04.1994 and build the kernel, booted my
> machine with it and the problems started. 
> Like building another kernel didn't work, as described in another
> mail. Then I wanted to run term, which didn't work either, so I tried
> to recompile it (term that is) but I got stuck with this:
> rm -f client.a
> ar rc client.a lib.o client.o terminal.o select.o socket.o connect.o
> ranlib client.a
> ranlib: client.a: Inappropriate file type or format
> gmake[1]: *** [client.a] Error 1
> gmake[1]: Leaving directory `/tmp/term114'
> gmake: *** [netbsd] Error 1
> When I went back to my old kernel and booted with that I could build
> kernels again, term worked and all the rest was btter as well. 
> Did I miss something? 
> btw. I'm using the latest binaries from sun-lamp.
> Thanks for any info. 
> Arthur.
> __
> Arthur Hoffmann					58/1 Dickward Drive
> 						Fannie Bay N.T. 0820
>				Darwin - Australia.