Subject: ADOSfs how?
To: None <>
From: Arthur Hoffmann <>
List: amiga-dev
Date: 04/10/1994 18:22:12
I followed the instructions on how to install the ADosFS on my A3000,
but It doesn't work.
This is what I did I configured the kernel as mentioned in the
README.LKM and rebooted the system. then I did the following:

root@atze(8)$ cp Makefile adosfsmod.c /usr/src/sys/adosfs/
root@atze(9)$ cd /usr/src/sys/adosfs/
root@atze(10)$ make
cc -O2 -I.. -I../sys -DKERNEL -DADOSFS -DADOSFSDEBUG -c adosfs_anode.c
cc -O2 -I.. -I../sys -DKERNEL -DADOSFS -DADOSFSDEBUG -c adosfs_blocks.c
cc -O2 -I.. -I../sys -DKERNEL -DADOSFS -DADOSFSDEBUG -c adosfs_util.c
cc -O2 -I.. -I../sys -DKERNEL -DADOSFS -DADOSFSDEBUG -c adosfs_vfsops.c
cc -O2 -I.. -I../sys -DKERNEL -DADOSFS -DADOSFSDEBUG -c adosfs_vnops.c
adosfs_vnops.c:725: warning: initialization of
`adosfs_vnodeops.vop_readdir' from incompatible pointer type
cc -O2 -I.. -I../sys -DKERNEL -DADOSFS -DADOSFSDEBUG -c adosfsmod.c
ld -r -o adosfs.o adosfs_anode.o adosfs_blocks.o adosfs_util.o adosfs_vfsops.o adosfs_vnops.o adosfsmod.o
root@atze(11)$ make load
modload -o adosfs -eadosfsmod adosfs.o
Module loaded as ID 0
root@atze(12)$ modstat
Type    Id  Off Loadaddr Size Info     Rev Module Name
VFS       0  13 004c2000 0018   4c6108   1 adosfs

Then I checked what my adospartition is called by the sysem:

root@atze(43)$ disklabel -r sd5
Bad pack magic number (label is damaged, or pack is unlabeled)
# /dev/rsd5a:
type: SCSI
label: some pack
bytes/sector: 512
sectors/track: 98
tracks/cylinder: 1
sectors/cylinder: 98
cylinders: 2097
rpm: 0
interleave: 0
trackskew: 0
cylinderskew: 0
headswitch: 0           # milliseconds
track-to-track seek: 0  # milliseconds
drivedata: 0 

9 partitions:
#        size   offset    fstype   [fsize bsize   cpg]
  a:    20678   184828    4.2BSD     1024  8192     0   # (Cyl. 1886 - 2096)
  c:   205561        0    unused        0     0         # (Cyl.    0 - 2097*)
  d:   102508    82222    4.2BSD     1024  8192     0   # (Cyl.  839 - 1884)
  i:    82026      196      ADOS                        # (Cyl.    2 - 838)
Warning, revolutions/minute 0

boot block size 0
super block size 0
partition a: partition extends past end of unit
partition c: partition extends past end of unit

So I checked in /dev for sd5i for rsd5i and sd5i, since they didn't
exist I created them, they look like this:

crw-r-----  1 root  operator    8,  56 Apr 10 18:03 rsd5i
brw-r-----  1 root  operator    4,  56 Apr 10 18:03 sd5i

Then I did:
mkdir /ados
mount -t adosfs -o ro /dev/sd5i /ados
the result of that was:

mount: Device not configured

What might the problem be? The minor number (56) for rsd5i|sd5i?

Thanks for any help.


Arthur Hoffmann					58/1 Dickward Drive
						Fannie Bay N.T. 0820			Darwin - Australia.