Subject: Re: GDB and MFS
To: David Jones <>
From: Chris Hopps <>
List: amiga-dev
Date: 03/24/1994 18:10:10
> - I still cannot mount mfs (can't read disklabel).  This worked in 744
>   and below.  Was a hack to get a BSD-style disklabel from an RDB image
>   broken somehow?

Works ok here.

> - vi is horribly slow.  It takes about 1/2 second to respond to anything
>   that requires screen scrolling.  I'm not sure if it's vi, or an
>   inefficiency in the ITE handling.  Also, I noticed this after I ran
>   the view-based X server.  Will do more experiments tonight.

I belive the nvi is slower than elvis however not the order of magnitude
you site.  Try setting TERM=vt320

> - Does _anybody_ have a version of GDB that works with the >= 744 proc
>   structure size?  The version of GDB on prep is 3 MB compressed, 15 MB
>   uncompressed.  I don't have the disk space required to compile it.
>   Also, it does not have a config entry for *-netbsd.

This sounds fishy.  The version you just installed should work fine.  I
made the necsessary modifications about a month back to sun-lamp's gdb.

Are you sure your running the new binaries and not old ones?  is /usr/gnu/bin
in your path before /usr/bin? If so are there copies of gdb in both 

>   Since a version of GDB was ported way way back, someone must have done
>   this already.  Is anybody in the process of building the new GNU tools?

It hasn't been much work but I am unaware of any problems with the GNU tools
contained in the binary distribution.

> David Jones, M.A.Sc student, Electronics Group (VLSI), University of Toronto