Subject: Re: GDB and MFS
To: David Jones <>
From: Chris Hopps <>
List: amiga-dev
Date: 03/24/1994 17:59:29
> OK, I got a new kernel and installed the new binaries (940319).  A few
> observations:
> - I still cannot mount mfs (can't read disklabel).  This worked in 744
>   and below.  Was a hack to get a BSD-style disklabel from an RDB image
>   broken somehow?

Hmm it works overhere, and I haven't heard of anyone else having problems.

> - vi is horribly slow.  It takes about 1/2 second to respond to anything
>   that requires screen scrolling.  I'm not sure if it's vi, or an
>   inefficiency in the ITE handling.  Also, I noticed this after I ran
>   the view-based X server.  Will do more experiments tonight.

Dunno, nvi appeared to me at first to be a little slower than elvis but not
on the order your talking about.  I doubt very much its an ITE thing.  Try
running with TERM=vt320.  The view based X server has absolutely nothing to
do with the ite as far as output goes.

> - Does _anybody_ have a version of GDB that works with the >= 744 proc
>   structure size?  The version of GDB on prep is 3 MB compressed, 15 MB
>   uncompressed.  I don't have the disk space required to compile it.
>   Also, it does not have a config entry for *-netbsd.

Um, again it works over here.  It sounds like your not running new binaries
or not a new kernel.  I made the nescessary modifications to sun-lamps gdb
about a month ago (whenever steve did his first binary set) it should work.

>   Since a version of GDB was ported way way back, someone must have done
>   this already.  Is anybody in the process of building the new GNU tools?

again the GNU tools in you /usr/bin directory should all work.  Perhaps you
still have old versions in /usr/gnu/bin and /usr/gnu/bin is before /usr/bin
in your PATH variable.

> David Jones, M.A.Sc student, Electronics Group (VLSI), University of Toronto