Subject: Re: GCC 2.4.5 didn't help me :-(
To: Eduardo E. Horvath <>
From: Arthur Hoffmann <>
List: amiga-dev
Date: 02/24/1994 12:29:37
> > My kernel problems with recent sun-lamp code persists when compiling with
> > 2.4.5.  I conclude the problems are generic for low-mem systems.  Are thera
> > anyone else running -current on 4 MBs?
> I'm running on a 4MB system.  I'm also using 2.5.6 (I think).  I find
> that I get very strange results.  I managet to get a bootable kernel
> ever other compile or so.  Problems ranged from a blank gray screen,
> to init dying from a trapsignal, to the latest version where init just
> dies.  The only soution I can suggest is don't compile with -O2, and
> if a kernel fails, delete all the .o files and try again.  I fand that
> after re-compiling the whole thing, the kernel will sometimes work.
> BTW, I do run mkdep on a kernel before I start compiling.  I'm getting
> the impression that mkdep may just be broken.
> =========================================================================
> Eduardo Horvath
> 					..!{decwrl,mips,fernwood}!btr!eeh
> 	"Trust me, I am cognizant of what I am doing." - Hammeroid
I am not so sure if it is related to your system being 4M, I have
tried to compile the sun-lamp kernel on my A3000 16M (fast) and I only
get a grey screen when loadbsd'ing vmunix.(loadbsd is the latest on
eunet) I'm using gcc2.5.8, ld.old and -O optimization. (O2 caused
heaps of undefined stuff when the compile was finished.) I also do a
make depend and I also tried to erase the whole ...../compile/ATZE
directory and doing a new config ATZE every time I did a sup to
sun-lamp. Also I did a make clean in /usr/src/sys/lib/libkern.

Any clues?


					Arthur Hoffmann