Subject: Re: Strange kernel problems
To: Niklas Hallqvist <>
From: Chris Hopps <>
List: amiga-dev
Date: 02/21/1994 04:47:08
> I've built both a kernel derived from the 940213 sources at sun-lamp
> as well as one from 940220.  Both behave well at first, but after some
> time, presumably after a certain amount of paging (I still run in 4MB!),
> all I can do is to execute bash internal commands.  Every other command
> results in "ls: is a directory" type of messages.  I haven't seen anything
> on current-users so I suspect it's Amiga-specific (or do all PC NetBSDers
> have a reasonable amount of memory?).  Has anoyone tried late versions on
> low-mem Amigas?  Typically starting emacs and stopping it (C-z) is enough
> to start this behaviour (well, I have never succeeded to do this anyway).
> There does not seem to be memory corruption going on, all in-core images
> run fine, it's just that I cannot start any new programs.

Hmm, I don't know but I am beginning to think that maybe the later
model gcc's (2.5.x) do something more with the kernel when compiled
with -02, try and change that to -O only and see if that clears
anything up.  I run with 2.4.5 all the time now so I can't check.

> Another note: as soon as I can get to compile a new kernel, I'll try my
> ADOSFS as a LKM, it really seems dead simple!!

Yeah I looked at the syscall stuf it seemed to work pretty cleanly.
Really looking forward to ADOSFS. :^) Thanks!

> BTW those of you who use late sun-lamp code *need* to recompile disklabel
> & newfs again as MAXPARTITIONS has changed once more.

Right, I don't think anyone relized that 32 partitions made the
disklabel struct 660 bytes :^)

> Niklas